Welcome to XMetaL Author

Built on a history of support for structured authoring, XMetaL Author offers unparalleled flexibility and performance. The best-of-breed feature set is designed to simplify your DITA-based authoring and deployment tasks.

XMetaL is designed for DITA

XMetaL is designed to make correct DITA markup automatically. You don’t have to memorize DITA markup rules or constantly think about its details. The content you create is continually checked for validity, and you are prevented from entering content that would make your document invalid.

XMetaL also supports DITA specializations with a minimum of setup work. You can also customize the formatting of DITA elements, for example, to treat them as tables.

XMetaL is WYSIOO

XMetaL is WYSIOO (What You see Is One Option), rather than WYSIWYG (What You See Is What You Get). Your documents are styled in a logical, easy-to-read way. For example, section titles are bold, and numbered lists are auto-numbered. However, there are differences between how your document looks in the editor and how it looks in print or HTML. This is because different stylesheets are used for producing output.

XMetaL is easy to configure

As you complete the exercises in this guide and become familiar with XMetaL, you may find things that you want to change and features you would like to add. You can easily customize the authoring environment and stylesheets. For example, you can do the following:

• Change the stylesheets for generating PDF and HTML output, to reflect corporate standards.
• Add or remove menu commands and toolbar buttons. For example, if you don’t want writers to use the <bold> element, you can remove the Bold toolbar button and inline element.
• Add a custom dialog box for recording topic metadata.
• Change the way that element IDs are automatically generated.
• Change the way topics are named. By default, XMetaL adds prefixes to topic file names to reflect the topic type, such as ‘c_’ for concept topics.

XMetaL can support different document types

XMetaL is designed to support DITA ‘out of the box’, and the exercises in this guide refer to examples of DITA documents.

However, your company may need to author documentation according to a standard other than DITA. Some companies set up XMetaL to efficiently create content for news websites, printed catalogs, training materials, forms, and legal contracts. Designing the XML vocabulary and the user interface for creating a new type of document requires a significant amount of setup work. If you need to work with these XML editor for a specific type of document, please contact us.

XMetaL is not ...

XMetaL is not a content management system. The content you create with XMetaL can be stored on your Windows file system, or in a source control or content management system.
XMetaL is not a page layout tool. It comes with stylesheets that are used to display your content in the editor and in the output you generate. You can customize the existing stylesheets or develop your own using another application.
Introduction to DITA authoring

If this is your first introduction to writing structured or topic-based content, take a few minutes to learn about why teams are adopting this strategy.

Why structured authoring?
XMetaL Author is a full-featured editor for creating structured documents in XML. Although word processors are useful for writing letters and ad-hoc documents, they cannot address the need to publish information in a standard format or re-use part of the content in another document. Structured authoring environments require authors to follow a defined set of rules that determine what kind of content can be added to a document and in what sequence. Rules are defined in a DTD (Document Type Definition) or schema file.

If you're new to structured authoring, you'll find that you can’t arbitrarily add content anywhere in a document. Structured environments direct you to place certain types of content at specific locations. Formatting and layout are determined not by authors, but by stylesheets. You can easily create and deploy stylesheets that meet the needs of your organization. By being relieved of the responsibility for formatting, writers can concentrate on writing.

Structured documents let you realize the following advantages:
- Eliminate the repetitive, time-consuming tasks involved in preparing content for publishing
- Ensure that your content satisfies regulatory or legal requirements, for example, by containing required warning messages
- Ensure that your content can be properly catalogued and searched
- Support for content re-use, for example, among service manuals for several products
- Allow content to be deployed in different formats, for example, in print and online
- Support for personalized content for different audiences
- Reduced localization costs, by localizing only the changed XML source, not the generated deliverables

Why Topic-Based Authoring?
The Darwin Information Typing Architecture (DITA) is an architecture for topic-based, structured XML authoring. As opposed to standards that support long, book-oriented writing, DITA is optimized for creating content in small, discrete units called topics that you then can organize in different ways to product output deliverables, including books, Web page content or online Help systems. You specify the organization for the deliverables using an XML file called a DITA map.

Why Topic-Typed Authoring?
DITA not only organizes content into topics, it also specifies a type for each topic. Each topic type has a specific set of rules for authoring content. For example, you cannot include a step in a concept topic because steps are only valid as part of a task. This structure guarantees consistency for all the topics of the same type. XMetaL provides templates so that you can start writing DITA-based topics quickly and easily.

If you need to either further restrict the structure of a topic or need to change the rules for a topic type, you can specialize the topic. However, this requires significant XML and DITA proficiency.
XMetaL advantages

XMetaL Author has some characteristics that set it apart from other DITA-based authoring solutions.

Content references

DITA supports reuse in several ways, one of which is by using the conref attribute to reference content from one topic or file into another. XMetaL enables you to create and manage content references by browsing to the target that you want to reference, so that you do not have to type file paths and element IDs. You can work with referenced content displayed within the document, as it would appear in output.

Conditional text

DITA has powerful support for creating multiple variations of a document from a single set of source files. You can configure XMetaL’s conditional text feature to use conditions specific to your organization, and then assign conditions to content using a simple dialog. You can then display conditional text with color-coding, and produce deliverables with complex sets of conditions by clicking a few checkboxes.

Integrated publishing capabilities

XMetaL integrates with the DITA Open Toolkit for publishing deliverables. You do not have to install the Toolkit separately. XMetaL also includes enhanced support for PDF output to improve bookmap generation. This support includes extended configuration options for PDF publishing for better control over output without XSL-FO programming.

Templates

By default, XMetaL includes templates for each DITA topic type, maps, and bookmaps. When an author creates a new topic, the template of the appropriate type opens and provides the commonly used elements for the topic. This helps new authors get started quickly and provides default structure for the topics. If the default templates do not contain the elements you want authors to use or if you want embed instructions in the templates, you can easily update them.

Natural Structured Authoring

XMetaL includes special features to support writing valid DITA, without having to know the details of DITA markup or having to view tags. For example, when you press Enter, XMetaL creates the most likely subsequent element to follow the current one. When you copy and paste formatted content from Word or HTML documents, XMetaL converts the formatted content to valid DITA markup.

Specialization support

Administrators can easily configure XMetaL to support specializations of DITA topics and maps.
Learn more

To learn more about DITA, check the following resources:

• XMetaL online Help and the XMetaL website at www.xmetal.com
• DITA Language Specification, available from the Help menu
• dita.xml.org
• Organization for the Advancement of Structured Information Standards (OASIS) at http://docs.oasis-open.org
• DITA Open Toolkit 1.3.1 Documentation Package from VR Communications at http://www.vrcommunications.com/resources.htm
• xmetal-dita and dita-users user groups on yahoo.com
About this guide

The exercises in this guide are designed to familiarize you with the XMetaL editor. Although they are designed to be done in order, you do not have to complete an exercise before moving on to the next one.

Sample files

Some exercises refer to sample files that are included with XMetaL. These files are located in the following folder: ..\XMetaL\Author\Samples.
Chapter 1

XMetaL at a glance

Views
XMetaL provides four ways to view the same document. Choose a view that you find most comfortable for your style of work and your level of expertise with DITA and XML.

Table 1: XMetaL Views

<table>
<thead>
<tr>
<th>Name</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>Normal</td>
<td>This is a styled view of your document, similar to word processors and HTML. When you work in Normal view, XMetaL keeps your document valid.</td>
</tr>
<tr>
<td>Tags On</td>
<td>Like Normal view, this is a styled view of your document. Element tags are displayed, indicating where elements start and end. When you work in Tags On view, XMetaL keeps your document valid.</td>
</tr>
<tr>
<td>Plain Text</td>
<td>This is an unformatted view of your XML content. This view is useful for troubleshooting or if you need to paste raw XML into your document.</td>
</tr>
<tr>
<td>Preview</td>
<td>This is a preview of how your document will look once it has been rendered as HTML. You cannot edit the document in this view.</td>
</tr>
</tbody>
</table>

Elements and attributes
Like every XML document, your DITA topic is associated with a DTD or schema. The DTD includes rules about what elements are allowed at any given point in your document. XMetaL continually ensures that your document remains valid. For example, the selection of elements available in the Insert Element pane includes only those elements that are valid at the insertion point. Also, when you try to insert elements using the menus or by cut and paste, XMetaL inserts the element at the next valid location in the document if it is not valid at the cursor location.

Choose a view
You can choose a view from the menu bar or from the view button bar. If you are not familiar with XML, try working in Normal view. If you are familiar with structured content, switch to Tags On view to see element boundaries.

1. Open the file About_These_Samples.xml.
   By default, the document appears in Normal view.
2. Do one of the following:
   - Click **View** and select a view
   - Click a view button at the bottom of the document editor

**Identify the current element**

The list of elements that are valid to insert depends on the position of the cursor in your document. The context bar displays the location of the cursor within the XML elements of the document.

Switch to Tags On view for this exercise.

1. Open the file `About_These_Samples.xml`.
2. Place the cursor within a List Item (`<li>`) element.
   - Check the context bar at the bottom of the editor. The context bar identifies the element in which the cursor is located, as well as all the ancestors of that element.

3. Select the list item including the opening and closing tags.
   - The following image shows that the context bar now shows the parent of the selected item.

**Display elements**

The **Insert Element** pane displays a list of the elements that are valid at the insertion point. You can choose to display all valid elements or the most frequently used (and valid) elements.

Switch to Tags On view for this exercise.

1. Open the file `About_These_Samples.xml`.
2. Place the cursor in the first paragraph (`<p>`) element.
3. If the **Insert Element** pane is not already visible, click **View > Element List** to display it.
   - By default, the pane displays the **All** tab. This list displays all the elements that are valid at the insertion point.
4. Move the cursor to another element in the file and observe how the list changes.
5. Click the **Used** tab.
   The **Used** tab displays only elements that are currently in use in open topics.
Create content

XMetaL includes many editing features you would expect to find in a word processor. However, if you work in Normal or Tags On view, some operations may be different than what you are used to. This is because XMetaL keeps your document valid as you work.

1. Open the file About_These_Samples.xml.
2. Now you can begin creating and editing content. As you edit, you’ll notice how XMetaL handles some common operations. Try the following:
   - Write some new sentences.
   - Click in different parts of the document and press the Enter key. You’ll see that XMetaL creates a new element that is appropriate for the context. For example, press Enter at the end of the topic title to create the Short Description element.
   - Highlight a selection of text in a paragraph and drag and drop it to another location. If the location is valid, XMetaL moves the selected text.
   - Copy and paste multiple paragraphs or tables from Word, Excel, or HTML. See how heading styles are mapped to sections, and lists to lists.
   - Select multiple paragraphs, and turn them into a bulleted list by clicking Insert > List > Bulleted List.
   - Select a paragraph, then click Paragraph > Change Paragraph Type > Note. XMetaL changes the selected paragraph to a note.
   - To Undo your changes, click Edit > Undo or press Ctrl+Z. XMetaL supports multiple levels of Undo.

Edit your document

Use the editing features to check spelling and find and replace. You can also track your changes.

1. Open the file About_These_Samples.xml.
2. Click Tools > Track Changes and make some changes to your document.
   Notice how changes are marked according to the type of modification made. You can accept or reject changes by clicking Tools > Accept or Reject Changes.
3. Choose Tools > Spell Checker and spell-check the document.
4. Choose Edit > Find and Replace to find and replace terms in the document.
Creating topics and maps

You may be familiar with writing a section or a chapter, but DITA focuses on a much smaller unit of information: the topic. The topic is the basic building block for DITA information. DITA provides the following topic types:

- **Concept.** For general, conceptual information such as a description of a product or feature.
- **Task.** For procedural information such as how to use a dialog.
- **Reference.** For reference information.

If you have completed the exercises that show you how to edit a document, you are already familiar with DITA topics. Open the file About_these_samples.xml and switch to Tags On view. Check the first or root element; it is `<concept>`. This means that the document is a concept topic.

You can organize topics into a DITA map or bookmap. A basic map allows a hierarchy of topics, and bookmaps also support book divisions such as chapters and booklists such as indexes. Maps do not actually contain topics, but rather references to them. These are known as **topic references**. Maps and bookmaps are saved with the extension `.ditamap`.

Maps can also contain relationship tables, which establish relationships between the topics contained within the map. Relationship tables are also used to generate links in your published document.

Many teams start writing projects by creating a map and then adding topic references to it. In XMetaL, you can create a DITA topic and insert a reference to it in one step. After you create the topic, you can double-click on the topic reference in the DITA map to open the topic.

You can use your map or bookmap to generate output using a deliverable type such as HTML Help or PDF.

### Create a map

The procedure for creating a map is similar to that for creating a topic. Use the menus to select the map template.

1. **Click File > New.**
2. **On the DITA Map tab, select DITA Map and click OK.**
   
   XMetaL opens the **Map Properties** dialog.
3. **Type a name for the map and click OK.**
   
   The Map Editor opens in the Resource Manager pane. Notice that there is a set of menus in the Map Editor.
4. In the Map Editor menus, click File > Save to save the map file.

Create a topic and add it to a map

You can create a topic and add it to a map through the Insert Topic Reference dialog. You can open topics by double-clicking in the Map Editor.

1. In the Map Editor, click Insert > Topic Reference.
   XMetaL opens the Insert Topic Reference dialog.
2. In the Topic Title field, type a title for your topic.
3. Click Create.
   XMetaL displays the New dialog.
4. Click the DITA Topics tab.
   XMetaL displays the topic templates. There is a template for each topic type.
5. Select Concept and click OK.
6. Type a filename and click OK.
7. Click OK to close the Insert Topic Reference dialog.
   The new topic appears in the map.

Organize topics in a map

It is easier to get a better understanding of how to organize topics in a DITA map using a populated map. Try moving topics by clicking and dragging and through the Map Editor menus.

1. Open the file Sample_Map.ditamap.
   This sample maps includes topics of different types.
2. Select the Starting a review project topic reference, then click the down arrow button on the map editor toolbar.
   The topic and all the topics nested within it move as a unit underneath the next topic at the same level (in this case, User accounts).
3. Select About use accounts and click Edit > Demote Item.
   The topic and all the topics nested within it move as a unit underneath the next topic at the same level.
4. Close the map without saving.

Create a bookmap

The procedure for creating a bookmap is similar to that for creating a map. Use the menus to select the bookmap template. You create a bookmap in the editor pane, not the Map Editor.

Switch to Tags On view for this exercise.

1. Click File > New.
   XMetaL displays the New dialog.
2. On the DITA Map tab, select DITA Bookmap template, and click OK.
   The bookmap opens in the editing pane and includes many common book elements.
3. Replace the template text with appropriate text for each of the desired elements. For example, click the Main Book Title text prompt and type 'My bookmap'.
4. Place the cursor in the <preface> element, then right-click and select Properties.
5. Browse to the Samples folder and select a DITA topic, then click OK. The preface now references the selected topic.
6. To insert a chapter, place the cursor within the <part> element, then click Insert > Chapter Reference, and specify a file for the new reference.
7. Save the bookmap file.

Specify relationships between topics

DITA supports specifying relationships that are manifested by links between topics using relationship tables.

1. Open the Sample_Map.ditamap file. This sample maps includes topics of different types as well as a relationship table.
2. From the map editor menu, click File > Switch to XML View of Map to display the map in the editing pane. The map includes a relationship table that specifies relationships between the topics in the map.
3. Place the cursor in the last row of the table and click the button on the table toolbar.
4. Copy the "Adding project participants" topic reference and paste it in the first cell of the new row. You include it in the first column because it is a task topic.
5. Copy the "About these sample documents" topic reference and paste it in the second cell of the new row to establish a relationship between the topics. You include this topic in the second column because it is a concept topic.
6. Right-click on the new "About these sample documents" topic reference and click Properties.
7. In the Topic Reference Properties dialog box, click the Special Attributes tab.
8. In the Linking field, select "Target Only", then click OK. The result of this setting is that the "Adding project participants" topic will contain a link to the "About these sample documents" topic, but the "About these sample documents" topic will not have a reciprocal link.

Create an index entry

You can specify index entries that apply to the entire topic or for a specific location in the topic. Index entries are used to create the index when you generate output.

Switch to Tags On view for this exercise.

1. Open the file About_These_Samples.xml file in Tags On view.
2. Place the cursor between the </shortdesc> and <conbody> tags, then insert prolog from the Insert Element pane. The <prolog> element contains metadata that applies to the entire topic.
3. Place the cursor within the <keyword> element, then click Insert > Index Marker.
4. In the Index term field, type: samples, about.
5. To add another index entry, click More Markers and type: sample topics, then click OK.
6. To add an index entry to a specific location in the topic, place the cursor at the beginning of the last paragraph, then click Insert > Index Marker.

7. Type sample topics, then click OK. The <indexterm> elements appears at the beginning of the paragraph.

8. Close the topic without saving.

**Insert a cross-reference**

When you insert a cross-reference to another topic, the title of the topic is displayed in the place of the cross-reference. Cross-references can also point to elements other than topics, such as tables and sections. Cross-references are difficult to create in tools that lack strong DITA support, but are straightforward in XMetaL.

1. Open the sample map file.
2. In the Map Editor view, double-click the title of any topic to open it.
3. Click in a paragraph in the topic.

> **Note:** DITA does not allow cross-references in the title or Short Description of a topic.

4. Click Insert > Link > Cross-Reference.
5. Click Browse.

6. Browse to and select another file from the DITA sample documents folder. Click OK. An <xref> element is inserted. The title of the topic you selected appears in the <xref> element.

7. View the attributes of the <xref> element you just inserted: In Tags On view, hover the mouse pointer over one of the <xref> tags. A tooltip appears. The href attribute includes the path to the file and the topic ID of the target topic. The type and format attributes have also been set automatically based on the target topic.


You can try generating output in multiple formats to see how cross-references appear. PDF output displays the topic title and page number. PDF, HTML, and help outputs display a hyperlinked topic title.

If you change the target topic title after you insert the cross-reference, the updated title is used when you generate output. You can make XMetaL display the updated title by clicking Edit > Refresh All References.
Chapter 3

Re-using content

For DITA experts: When you insert referenced content, XMetaL adds an element with a conref (content reference) attribute that points to the referenced content. You can create content references to any DITA element.

XMetaL provides the following ways of re-using content:

• You can select content in a topic and create a reusable component from it. A reusable component is a file, usually shorter than a topic. You also have the option of replacing the selection with the component that you are in the process of creating.
• You can attach a content reference to an existing element.
• You can insert an element with a content reference.

DITA makes the distinction between local content, that is the text and graphics that are actually present in the element, and referenced content that is referred to by the element. You have the option of displaying local content or referenced content.

Working with content references

DITA has a feature called conref (short for "content reference") which enables a piece of content to be included by reference in multiple contexts. When you need to update that content, you need to update it in only one place. Typical uses of content references are for product names, warnings, and definitions.

XMetaL includes rich functionality for creating, viewing, and managing content references.

You can use either or both of the following strategies for managing content references:

• Reusable Components: With this strategy, you create a new file for each piece of content that you want to reuse.
• Arbitrary content references: You may prefer to keep many pieces of reusable content in one file. For example, you might want one file to consist of a list of product names, with each product name in a "phrase" (<ph> element) within the file. Then, wherever you need to display a product name, you can insert a content reference that points to the appropriate <ph> element in this file.

This strategy requires more setup work than using Reusable Components, but makes it easier to centrally manage what content is reused.

How content references work

Whether you use Reusable Components or arbitrary content references, XMetaL creates the reference to the external content by adding a conref attribute to an element in the local document. The conref attribute defines a link to the referenced content, made up of a path to the file and the topic ID within the file. The path may also reference a specific element ID within the topic. Referenced content is not physically copied to the referencing
file, however XMetaL displays it as if it were actually there. You can also choose to view "local content" instead of referenced content, to edit the attributes or contents of the referencing element.

**The Reusable Component model**

This section describes the inner workings of Reusable Components. Most users do not need to understand these details in order to use Reusable Components, however the information may be of interest to system administrators or information architects.

The Reusable Component file has `<ditacomponent>` as its root element. The `<ditacomponent>` element type is specialized from the DITA `<topic>` element type. The `<compbody>` element type is specialized from the DITA `<body>` element type, and the `<reusable-content>` element type is specialized from the `<required-cleanup>` element type. All of these are valid DITA specializations.

If you insert a Reusable Component, XMetaL inserts an element with the same element type as the contents of the Reusable Component, with a `<conref>` attribute that points to the element within the `<reusable-content>` element.

### Create a reusable component

You can select text in a document and create a reusable component from it using the XMetaL menus. This procedure describes how to create a reusable component and a reference to it in one step.

For this exercise, switch to Tags On view.

1. Open the file `About_These_Samples.xml`.
2. Select the text "Task, Concept, and Reference", then click **Reuse > Create Reusable Component** and click **Continue**.
3. Select the **Replace selected content with a reference to the new component** option and click **Continue**.
4. Save the reusable component file as `TCR.xml`.
   The selected text has now been replaced with a reusable component. It appears with a gray background indicating that it is non-editable.
5. Place the cursor in another location in the file, then click **Reuse > Insert Reusable Component**.
6. Select the reusable component file `TCR.xml`, then click **OK**.
   XMetaL Author inserts the reusable component. Note that it has a grey background to indicate that it is non-editable. Tildes on either side indicate that this is a phrase `<ph>` element.
7. Click the text that you just inserted.
   The entire phrase, "Task, Concept, and Reference" is highlighted.
8. Optionally, click **Reuse > Show Local Content**.
   The text disappears, and the tildes appear against a yellow background. The yellow background signifies that you are viewing local content for an element that has a content reference.
9. Click **Reuse > Open Referenced File**.
   The reusable component file (TCR.xml) opens.
10. Make a change in the TCR.xml file, then save the file.
11. Click **Window > About_These_Samples.xml**.
12. Click **Edit > Refresh All References**.
   The change you made in TCR.xml is reflected in your view of the document.
13. Close the topic without saving.
Insert a direct content reference

This exercise shows you how to insert an element with a content reference, that points to an element that is not in a reusable component file.

1. Open the file About_These_Samples.xml.
2. Click at the end of last paragraph in the file.
3. Click Reuse > Insert Element with Content Reference.
4. In the Select an Element list box, select the element ID beginning with "ul_".
   A preview showing three bulleted list items appears.
5. Click OK.
   A <ul> element is inserted, with a conref attribute pointing to the other <ul> element. The new <ul> element is selected.
Chapter 4

Working with conditions

By default, XMetaL comes with the following conditions:

- Audience
- Platform
- Product

Each condition defines values. For example, Audience includes values of "Administrator" and "User" by default.

You can specify your own conditions through the following configuration file: ..\XMetaL\Author\Conditional Text\configs\ct_config.xml.

Without specializing DITA, you can:

- Change the values for Audience, Platform, and Product. E.g. configure the system to use your own product names.
- Add a fourth condition, to be stored using the DITA otherprops attribute. For example, you can add a "Location" condition with values of "on-site" and "mobile".

For DITA experts: If you need more than four conditions, you can create new ones by specializing the otherprops attribute. You can then configure the system to use those new attributes.

Apply conditions

You can apply conditions to text and images in your document through the Apply/Remove Conditions dialog.

For this exercise, switch to Tags On view.

1. Open the file About_These_Samples.xml.
2. Select some text in the first list item.
3. Click Reuse > Apply/Remove Conditions.
4. From the **Audience** category, select **Administrator**, then click **OK**.

XMetaL Author automatically creates the `<ph>` tags that are necessary to mark the conditional range. The conditional range appears with a colored background, with ~ symbols before and after it.

If you do not see `<ph>` tags or ~ symbols, it is because you selected an entire element, rather than text within an element, before you chose the condition to apply.

5. Optionally, change the appearance of the conditional text by clicking **Reuse > Style Conditional Text**.

6. Save and close the document.

---

**Create a condition**

You can create your own conditions in the Condition Configuration File. You can add values to the existing default conditions or create your own DITA lets you define conditions through the attribute element that has the name 'otherprops'. After you modify the configuration file, you need to re-start XMetaL.

In order to create your own conditions, you must be able to read and understand XML. This topic is intended for advanced users.

1. Open the file `..\XMetaL\Author\Conditional Text\configs\ct_config.xml`.
2. Add a new `<value>` element with the name 'evaluator'.
   For example,
   ```xml
   <attribute name="audience" title="Audience">
     ...
     <value name="evaluator" title="Evaluator" />
   </attribute>
   ```
   Use the title attribute to indicate how the condition value should appear in the XMetaL interface.

3. Now try creating a new condition and values.
   The following example creates a new condition called 'Release', with values of 'Beta' and '1.0'.
   ```xml
   <attribute name="otherprops" title="Release">
     <value name="beta" title="Beta" />
     <value name="1.0" title="1.0" />
   </attribute>
   ```
Chapter 5

Publishing

The DITA Open Toolkit is installed when you install XMetaL Author and you can run it through the Generate Output menu item. You get the same results that you would using the toolkit directly, but XMetaL is much easier to use.

The format and characteristics of your output is determined by saved configuration called a deliverable type. By default, XMetaL includes deliverable types for several standard output formats.

Note: If you want to create Microsoft HTML Help (CHM) output, ensure you have Microsoft HTML Help Workshop installed. This is available from www.microsoft.com.

Generate output

You can generate output from the sample map files. You can specify which conditions to include in your output.

This exercise requires Microsoft HTML Help Workshop.

1. Open the file Sample_Map.ditamap.
2. Click File > Generate Output for DITA Map.
3. Select the HTML Help (CHM) deliverable type, then click Show/Hide Conditional Text.
   You can now select conditions that you want to appear in the output. The settings are retained for all subsequent output.
4. From the Audience condition, select Administrator and click OK.
   XMetaL begins the process of creating output for your document.
5. At the end of the generating process, click Open File.
   Open the generated CHM file and click through the topics to see how the generated links appear in the parent and child topics, as well as the Related links specified by the relationship table.
6. Now create a PDF file for your document. Click File > Generate Output for DITA Map and select XMetaL Enhanced PDF, then click OK.
7. Open the generated PDF document and browse through the document to see how same information appears in the different output format.

Generate output with complex conditions

This exercise shows you how to generate output for content that is conditionalized for multiple audiences and multiple platforms.
For this exercise, use the table below as an example. This table already has conditions applied. For example, row 3 has been conditionalized to indicate that it applies to the "Administrator" audience and the "Windows" platform.

<table>
<thead>
<tr>
<th>#</th>
<th>Sample</th>
<th>Audiences</th>
<th>Platforms</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>The PrintFlamingo system stores important settings in a configuration file.</td>
<td>All</td>
<td>All</td>
</tr>
</tbody>
</table>

1. Open the file `t_Generate_output_with_complex_conditions.xml` from your `C:\Program Files\XMetaL\Author\Evaluation Guide\tasks` folder.

2. Optionally, view what conditions are used in the document:
   a) Click anywhere in row 3 of the table above.
   b) Click `Reuse > Apply/Remove Conditions`.
   c) From the Conditional Range drop-down list, choose "row". The dialog displays which conditions apply to table row 3.

3. Click `File > Generate Output for DITA Topic`.

4. In the `Generate Output for DITA Topic` dialog, click `Show/Hide Conditional Text`.

5. Expand the `Audience` node and select the `Administrator` checkbox. Expand the `Platform` node and select the `Mac OS X` checkbox. Click OK.

6. In the `Generate Output for DITA Topic` dialog, choose any deliverable type, and click OK.

In output, only rows 1, 2, and 4 of the table appear. This is what you want: all material that is needed by administrators using a Macintosh, and no material that is irrelevant to them. To get this result using other tools, you would probably have had to create conditions such as "Macintosh not-administrator" for the other rows.

You can experiment with styling of conditions using this file. When viewing the document in XMetaL, note that by default, all conditional text is colored with a light blue background. You can configure this by choosing `Reuse > Style Conditional Text`, for example to style content for Windows in green text and content for the Macintosh in red text.
Index

A
authoring
  structured 7
  topic-based 7
  topic-typed 7

B
bookmaps 20

C
CHM output 29
condition configuration file 27
conditions 27, 28, 29
  applying 27
  creating 28
  publishing with 29
conref attribute 24
content reuse 24

D
deliverables
  CHM 29
  HTML 29
  PDF 29
DITA 7
DITA bookmaps
  create 20
DITA maps 19

E
editing 18
Element List
  displaying elements 16
  elements
    identifying currently selected 16
    displaying in Element List 16

F
Find and Replace 18

G
generating output 29

H
HTML output 29

I
index entries 21

M
maps
  adding topics 20
  bookmark 20
  creating 19
  organizing topics 20
  relationship tables 21

N
Normal view 15

P
PDF output 29
Plain Text view 15
Preview view 15

R
related links 21
relationship tables 21

S
specialization 7
spell checker 18
structured authoring 7

T
Tags On view 15
topic-based authoring 7
topic-typed authoring 7
topics
  adding to maps 20
  creating 20
  organizing in maps 20
  relationships between 21
Track Changes 18
V

views (continued)
change 15